P.I.D. instel probleem

Aanbieders, zelfbouw projecten, ervaringen etc mbt 3D printer bouwpakketten en onderdelen.
Plaats reactie
hardy
Berichten: 256
Lid geworden op: 27 jun 2017, 11:49
Locatie: Twente
Contacteer:

P.I.D. instel probleem

Bericht door hardy » 15 aug 2019, 22:03

Mij zelfbouw Cube heeft vandaag zijn eerste proef printje uitgespuugd en zag er niet echt verkeerd uit, maar er moet nog wel het één en ander ingesteld en veranderd worden.
Het probleem waar ik nu tegenaan loop is, dat ik met M303 de auto tune PID waarden heb bepaalt en ingegeven, maar hierna wil de printer niet meer de print opdracht starten, ik heb dit verschillende keren opnieuw uitgevoerd, de printer warmt wel normaal op en houd de nozzle temperatuur ook mooi op +/- 2graden constant, maar gaat dan niet over op printen.
Als ik mijn oude waarden er weer inzet, dan werkt het wel weer, dit zijn waarden die ik van mijn andere printer heb overgenomen die met een 12v systeem/heater werkt, maar in mijn Cube heb ik nu alles op 24v en dus dacht ik dit even beter opnieuw precies in te stellen.
Wie weet waarom dit fout gaat?

Hardy

Rob52
Berichten: 700
Lid geworden op: 21 nov 2018, 12:35
Locatie: Gendringen
Contacteer:

Re: P.I.D. instel probleem

Bericht door Rob52 » 15 aug 2019, 22:31

Het is een gokje, maar voordat de printer kan gaan printen moet de temperatuur gedurende 10 seconden stabiel zijn. Dat is geloof ik 1 á 2 graden. Nu schrijf je dat de temperatuur mooi stabiel blijft op +- 2 graden. Mogelijk dat er toch nog teveel afwijking is en er dus geen 10 seconden een stabiele temperatuur gemeten wordt. Misschien een beetje spelen met de waardes en kijken of dit verschil maakt.

(De complete uitleg van PID is vrij complex maar is in feite het anticiperen op komende temperatuurafwijkingen om zo te kunnen stabiliseren. De P is de proportionele band. Zodra de temperatuur daar binnen komt neemt de steilheid van de temperatuurstijging af om zo overshoot te voorkomen. I en D zijn nog weer verfijningen die het verloop naar het setpunt nog gladder moeten doen verlopen. Verkeerde waarden hebben uiteindelijk een averechts effect. Vandaar dat er gelukkig auto tuning is die door eerst een overshoot te forceren berekeningen maakt om de PID waarden te bepalen.)
Groeten, Rob.

* Gemodificeerde Anet A8
* Anycubic Kossel Lineair Plus

Bobby
Berichten: 45
Lid geworden op: 24 dec 2017, 23:22
Locatie: Bergen op Zoom
Contacteer:

Re: P.I.D. instel probleem

Bericht door Bobby » 16 aug 2019, 00:38

Mocht je de mogelijkheid hebben om vanaf een computer via USB te printen hebben de meeste programma's een monitormogelijkheid om de systeemmeldingen te zien (bv de terminal tab in Octoprint of het logvenster in Repetier-host). Die meldingen zullen waarschijnlijk informatie en/of een foutmelding laten zien, zodat je wat gerichter kan troubleshooten

hardy
Berichten: 256
Lid geworden op: 27 jun 2017, 11:49
Locatie: Twente
Contacteer:

Re: P.I.D. instel probleem

Bericht door hardy » 16 aug 2019, 11:37

Rob52 schreef:
15 aug 2019, 22:31
Misschien een beetje spelen met de waardes en kijken of dit verschil maakt.
Dan is het dus weer gokken ;) ;) , dan kan ik ook gewoon de oude instellingen gebruiken, want die werkten uiteindelijk wel, maar ik ben nu wel iets verder, er zijn verschillende voorbeelden te vinden hoe het zou moeten, ik liet dus met M303 de PID berekenen van een temperatuur van 230graden, ik heb het nu gedaan met 200graden, en dan komen er veel lagere waardes uit die dichter op mijn oude waardes zitten, de printer werkt nu wel weer, maar de fluctuaties zijn op het display wel groter op het display, +/- 5gr, wel raar eigenlijk dat het nu wel werkt, want op de 230graden was het veel constanter met minder afwijkingen.

Hardy

Plaats reactie

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 1 gast