3D print resultaten niet zoals gewenst.

Show hier resultaten, projecten en vooruitgang van je 3D prints
Zappa
Berichten: 32
Lid geworden op: 08 nov 2019, 16:29
Contacteer:

Re: 3D print resultaten niet zoals gewenst.

Bericht door Zappa » 17 nov 2019, 12:36

Nog even dan, en dan moet ik achter de stofzuiger.

Hier een plaatje dat de kwaliteit laat zien, net nadat ik de EEPROM settings vernaggeld had (zie eerdere post). Hier wordt met de standaard printerconfiguratie geprint, waarbij:
"17:00:28.307 : echo:Maximum feedrates (units/s):
17:00:28.313 : echo: M203 X300.00 Y300.00 Z5.00 E0.00
17:00:28.316 : echo:Maximum Acceleration (units/s2):
17:00:28.319 : echo: M201 X3000 Y3000 Z100 E3000
17:00:28.324 : echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
17:00:28.329 : echo: M204 P800.00 R800.00 T1000.00
17:00:28.338 : echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
17:00:28.343 : echo: M205 S0.00 T0.00 B20000 X40.00 Y40.00 Z0.40 E0.00
"


Afbeelding

De linker print is dus gemaakt met de bovenstaande configuratie settings. De rechter print is gemaakt met de onderstaande settings:
"20:19:44.823 : echo:Maximum feedrates (units/s):
20:19:44.828 : echo: M203 X300.00 Y300.00 Z5.00 E25.00
20:19:44.831 : echo:Maximum Acceleration (units/s2):
20:19:44.834 : echo: M201 X300 Y300 Z100 E500
20:19:44.839 : echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
20:19:44.845 : echo: M204 P300.00 R800.00 T500.00
20:19:44.853 : echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
20:19:44.859 : echo: M205 S0.00 T0.00 B20000 X7.00 Y7.00 Z0.40 E1.00
"

Ik heb de acceleration teruggebracht van 3000mm/s*s naar 300mm/s*s. Dat had een kleine zichtbare verbetering tot gevolg. De grootste verbetering zit in het terugschroeven van de jerk van 40 naar 7 (10 werkt ook wel, vanaf 15 zie ik meer lagen verschijnen waarbij de lijnen naar binnen liggen).

Nog een plaatje. Links met de bovenste configuratie, rechts met de onderste.

Afbeelding

De jerk setting lijkt dus veel effect te hebben.

Als ik met een sterke loep de linker print bekijk dan lijkt het effect wat je ziet niet te maken te hebben met onderextrusie. Het lijkt er eerder op dat die lijnen te veel naar binnen worden gelegd over (bijna) de hele omtrek van de print. Dus in zowel de X als de Y richting ligt er een lijn meer naar binnen. De volgende layers worden dan weer goed gelegd, totdat er weer eentje tussenzit die meer naar binnen ligt. Bij de rechter print zie ik hetzelfde, hoewel de 'verkeerde' lijnen daar minder naar binnen liggen dan bij de linker print. Dus het effect is minder duidelijk aanwezig bij de lagere jerk setting van 7.


Ik heb trouwens nog een vraag, waar ik op Internet geen duidelijk antwoord op vind:
De gcode M204 (M204 P300.00 R800.00 T500.00), wat doet deze instelling precies? Wat is het verschil tussen deze setting en de acceleration settings die met gcode M201 worden ingesteld?
Printer 1: Wanhao Duplicator i3+
Printer 2: Momenteel een Wanhao D9 400 die niet goed werkt...
Overig: Palette 2
Print met: 123-3d, AprintaPro, FilamentWorld, Fillamentum, FormFutura, Innofil, Polymaker, PrimaCreator, ProtoPasta.
SW: Fusion360, S3D

Rob52
Berichten: 1041
Lid geworden op: 21 nov 2018, 12:35
Locatie: Gendringen
Contacteer:

Re: 3D print resultaten niet zoals gewenst.

Bericht door Rob52 » 17 nov 2019, 13:49

De jerk settings hebben veel invloed heb ik zelf ook gemerkt. Het woord zegt het al jerk -> ruk (in de nette betekenis :lol: ) Hoe hoger die staat hoe meer abrupte beweging je krijgt wat invloed kan hebben op mechanische speling en tolerantie in je assen. Minder jerk en langzamer printen geven dan vaak een beter resultaat.

Een goede uitleg van de diverse G-codes vind je op de Marlin website zelf. Daar staat ook de uitleg betreffende M204.
Usage
M204 [P<accel>] [R<accel>] [T<accel>]
Parameters
[P<accel>]
Printing acceleration. Used for moves that include extrusion (i.e., which employ the current tool).

[R<accel>]
Retract acceleration. Used for extruder retraction moves.

[T<accel>]
Travel acceleration. Used for moves that include no extrusion.
Groeten, Rob.

* Gemodificeerde Anet A8
* Anycubic Kossel Lineair Plus

Zappa
Berichten: 32
Lid geworden op: 08 nov 2019, 16:29
Contacteer:

Re: 3D print resultaten niet zoals gewenst.

Bericht door Zappa » 20 nov 2019, 18:05

Na het draaien van een hoop testprintjes, met verschillende instellingen...

Afbeelding

Denk ik dat ik een belangrijke oorzaak van mijn probleem op het spoor ben. Wie het ziet mag het zeggen:

Afbeelding

Onderstaande foto's laten het verschil zien tussen de kwaliteit van alle vorige prints en de kwaliteit die ik nu haal.
Het bovenste print is steeds de laatste print. Het onderste printje is er een (van vele) van voor mijn ontdekking.

Afbeelding

Afbeelding

Afbeelding
Printer 1: Wanhao Duplicator i3+
Printer 2: Momenteel een Wanhao D9 400 die niet goed werkt...
Overig: Palette 2
Print met: 123-3d, AprintaPro, FilamentWorld, Fillamentum, FormFutura, Innofil, Polymaker, PrimaCreator, ProtoPasta.
SW: Fusion360, S3D

Rob52
Berichten: 1041
Lid geworden op: 21 nov 2018, 12:35
Locatie: Gendringen
Contacteer:

Re: 3D print resultaten niet zoals gewenst.

Bericht door Rob52 » 20 nov 2019, 18:48

Enige verschil dat me zo opvalt buiten het kwaliteitsverschil is de Z-naad.
Groeten, Rob.

* Gemodificeerde Anet A8
* Anycubic Kossel Lineair Plus

Caved
Berichten: 357
Lid geworden op: 24 dec 2017, 12:17
Locatie: Enschede
Contacteer:

Re: 3D print resultaten niet zoals gewenst.

Bericht door Caved » 20 nov 2019, 20:56

Het apparaatje zegt unregular extrusion verder valt het verschil op in afwerking en de Z naad op die ene.
Zo'n wasknijper veer als band spanner lijkt me zelf ook niet de oplossing. Dan nog is de ronding rechts op
de wat nettere print niet mooi. Ik zou die wasknijper er af gooien en de band fatsoenlijk spannen.

Maar euh, wat was jij nu op het spoor dan?
Mvg
Caved

:idea: "Thinking outside the box" :idea:

Thingiverse
http://www.thingiverse.com/caved12/designs

CGTrader
https://www.cgtrader.com/caved

Printers:
FLSun Cube (Crealified)
Ender 3 (Oud werk beesje)

Design Software:
DS Mechanical

hardy
Berichten: 413
Lid geworden op: 27 jun 2017, 11:49
Locatie: Twente
Contacteer:

Re: 3D print resultaten niet zoals gewenst.

Bericht door hardy » 20 nov 2019, 22:11

Hadden we hier toch al direct aangegeven dat de riemen in ieder geval goed gespannen moeten zijn !!, want dat is toch de eerste indruk bij zo'n slechte print.
Die spanveertjes kunnen overigens wel goed werken, ik heb ze ook in mijn ultifaker zitten, helaas ik heb daar gewoon geen andere span mogelijkheid, maar er wordt bij mij ook bijna geen massa verplaatst.

Hardy
zelfbouw eigen ontwerp ULTI(F)AKER
zelfbouw eigen ontwerp CUBE-3D

Rob52
Berichten: 1041
Lid geworden op: 21 nov 2018, 12:35
Locatie: Gendringen
Contacteer:

Re: 3D print resultaten niet zoals gewenst.

Bericht door Rob52 » 20 nov 2019, 22:19

Op de Anycubic Kossel heb ik die veertjes ook zitten en dat werkt prima. Is zelfs standaard zo.
Groeten, Rob.

* Gemodificeerde Anet A8
* Anycubic Kossel Lineair Plus

Zappa
Berichten: 32
Lid geworden op: 08 nov 2019, 16:29
Contacteer:

Re: 3D print resultaten niet zoals gewenst.

Bericht door Zappa » 20 nov 2019, 22:29

De 'Unregular extrusion' is een deel van de naam van mijn testprint.

Het verschil van die laatste print ten opzichte van álle andere prints die ik tot nu toe op de D9 heb gedaan, is dat ik het bed heb uitgelaten. Normaal staat deze bij PLA op 60 graden. Ik heb nooit op een koud bed hoeven printen, ook niet op mijn i3+. Ik was altijd blij dat ik geen gebruik hoefde te maken van die schilderstape en dat ik met een beetje haarlak zowel PLA, PETG als Flex kon printen op een verwarmd bed.

Ik merkte vandaag dat de bedtemperatuur heel snel schommelt tussen de 60.7 en de 59.3 graden. Dat is op zich niet veel. Die schommelingen hebben te maken met de aan-uit regeling van het bed die de D9 doet. De frequentie van het op en neergaan ligt op zo'n 2.5 tot 3 keer per minuut. Toen ik de print in de gaten hield, viel mij op dat als de bedverwarming aan gaat (dalende temperatuur, schakelpunt net onder de 60 graden), de lijnen die neergelegd werden net iets dunner waren (onderextrusie). En zodra de bedverwarming uit gaat (stijgende temperatuur, schakelpunt op 60 graden) de lijnen weer van normale dikte werden. De bedverwarming heeft invloed op de extrusie.

Het resultaat zie je steeds in al mijn eerdere plaatjes. De layers zijn van ongelijke dikte, waarbij een aantal meer naar binnen lijken te liggen ten opzichte van de rest. En over het algemeen zit er geen regelmaat in die layers in de Z richting. Het patroon lijkt eerder steeds random te zijn als ik de verschillende prints met elkaar vergelijk.
Alle aanpassingen en andere wijzigingen in instellingen die ik tot nu toe heb gedaan om in ieder geval in één richting (X, Y of Z) verbetering te krijgen, hebben ten hoogste slechts een marginale verbetering tot gevolg gehad. Het grootst zichtbare probleem bleef steeds aanwezig. En het lijkt er op dat het geen probleem in een van de assen is.

O.a. jullie hebben mij weer op het spoor gebracht van de temperaturen van hot end en bed in de vorige posts. De temperatuur van het hot end is dik in orde, afgaande op de gerapporteerde temperaturen. Het hot end blijft netjes tussen de 229.9 en 230.2 graden, als deze is ingesteld op 230.
Het bed blijft op zich ook netjes op temperatuur. Het viel mij alleen op dat het wisselen tussen de maximum en minimum temperatuur een aantal keer per minuut voorkomt. Toen bedacht ik dat, als deze regelmaat op enige manier invloed zou kunnen hebben op de extrusie, dan zou dit in een print zichtbaar kunnen worden als een onregelmatig patroon zoals ik steeds zie (óf als een regelmatiger patroon maar dat dan erg afhankelijk is van de grootte en regelmaat van het te printen object). In ieder geval kon het geen kwaad om eens close op de print te gaan zitten en zowel het aan-en-uitspringen van het hot bed als de extrusie die dan wordt neergelegd in de gaten te houden. Toen viel mij het kleine verschil in extrusie op en de mogelijke relatie met de temperatuurregeling van het bed.

Ik heb de afgelopen avonden nog eens het Internet afgespeurd naar informatie voor de problemen waar mijn printer mee kampt. Ik kwam toen deze link op de Ultimaker community tegen. Ook de laatste post met deze link daarin naar een Google group. De informatie in deze threads liet mij denken dat het hele probleem met de printer ook wel eens elektrisch gerelateerd kon zijn.

Het vermogen van de voeding zou een probleem kunnen zijn. Als het bed inschakelt en de voeding kan het gevraagde vermogen niet leveren dan zou dat vreemde gevolgen kunnen hebben voor de elektronica van de printer en de aansturing ervan.
Er zou misschien sprake kunnen zijn van interferentie tussen het vermogensdeel van het bed en de aansturing van een stappenmotor zoals die van de extruder. Het zou vreemd zijn, want de kabels naar het bed lopen heel anders dan die van de extruder. Maar toch...

Dat zijn twee mogelijke oorzaken. Misschien weten jullie er nog enkele?
De eerste zou ik nog vrij makkelijk moeten kunnen meten, met een multimeter aan de 24V pennen van de voeding. De tweede lijkt mij een heel stuk lastiger aan te tonen.

Als een soort van disclaimer wil ik zeggen dat dit zeker niet het enige probleem is dat de printkwaliteit beïnvloedt. Zelfs in de laatste print zitten nog genoeg andere zaken die mij niet bevallen en voor een belangrijk deel printergerelateerd zijn (Er zitten er ook een aantal die met de slicer aangepakt kunnen worden). Het verschil tussen deze print en al die andere was mij echter te groot om dit uit te sluiten als een gebied waar mogelijk winst te halen valt qua printkwaliteit, zeker omdat alle andere verbeteringen die ik tot nu toe zag veel kleinere verschillen in kwaliteit opleverden.

Als hier inderdaad iets te halen valt in de voeding of interferentie, dan kan ik op zoek naar de oorzaken van die andere fenomenen die ik zie. Zoals die wasknijper op de X band ;). Dat zou eindelijk eens een doorbraak betekenen in mijn 4 maanden durende zoektocht naar een betere printkwaliteit voor mijn D9.

Wat denken jullie?
Zou een van de problemen van mijn printer voedingsgerelateerd kunnen zijn?
Wat zou, vanuit de bril van voeding of elektronica gekeken, nog meer een rol kunnen spelen in de printkwaliteit?
Welke metingen zou ik kunnen doen om iets te bevestigen of te ontkrachten? Ik heb 2 multimeters en een scope.
Printer 1: Wanhao Duplicator i3+
Printer 2: Momenteel een Wanhao D9 400 die niet goed werkt...
Overig: Palette 2
Print met: 123-3d, AprintaPro, FilamentWorld, Fillamentum, FormFutura, Innofil, Polymaker, PrimaCreator, ProtoPasta.
SW: Fusion360, S3D

Rob52
Berichten: 1041
Lid geworden op: 21 nov 2018, 12:35
Locatie: Gendringen
Contacteer:

Re: 3D print resultaten niet zoals gewenst.

Bericht door Rob52 » 20 nov 2019, 23:22

Het onderwerp voeding is al meerdere keren als mogelijke oorzaak langsgekomen.

Je zou eens kunnen controleren of het vermogen van de voeding ruim genoeg is voor alle verbruikers. Tijdens het printen zou je bij een te zwakke voeding een spanningsdip, hoe klein dan ook, moeten zien op het moment dat er teveel aanstaat. Dat is met een multimeter eenvoudig te meten. Meten is weten, dus ga niet uit van wat de stickers zeggen dat de voeding zou moeten kunnen. Het zal de eerste voeding niet zijn die niet waar maakt wat erop staat.

Je zou ook de temperatuur van het bed kunnen instellen op een temperatuur die slechts een paar graden boven de omgevingstemperatuur ligt. Daardoor blijft de verwarming telkens een stuk langer uit en is slechts eventjes aan omdat er minder temperatuurverlies is. Je zult dan ook minder verstoring zien als zich weer hetzelfde voordoet. Je kunt ook het bed voeden met een externe voeding via een mosfet en kijken wat er dan gebeurt. Door de mostfet is de verwarming van het bed, via een opto coupler, galvanisch gescheiden van de regeling. Als je tenminste een andere voeding voor het bed gebruikt en als je zo'n kant en klaar mosfet bordje toepast waar een opto coupler op zit.

Interferentie door storingssignalen zullen met een scope wel meetbaar zijn, maar de vraag is waar je moet gaan meten. Zoals Caved al eens heeft gedaan zou je eventueel kunnen overwegen om datakabels in aluminiumfolie te wikkelen.
Groeten, Rob.

* Gemodificeerde Anet A8
* Anycubic Kossel Lineair Plus

Caved
Berichten: 357
Lid geworden op: 24 dec 2017, 12:17
Locatie: Enschede
Contacteer:

Re: 3D print resultaten niet zoals gewenst.

Bericht door Caved » 20 nov 2019, 23:30

Je kan proberen je vref van je E stepper wat op te schroeven kijken wat dat doet voor
je print. Ik denk ff mee.. Maar als je voeding te licht is moet je m gewoon vervangen
voor een zwaardere, gewoon beter om wat over te hebben IMHO
Mvg
Caved

:idea: "Thinking outside the box" :idea:

Thingiverse
http://www.thingiverse.com/caved12/designs

CGTrader
https://www.cgtrader.com/caved

Printers:
FLSun Cube (Crealified)
Ender 3 (Oud werk beesje)

Design Software:
DS Mechanical

Plaats reactie

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 3 gasten